Dans cette solution, vous allez trouver la partie technique du géoréférencement.


1. Définition du géoréférencement et mensuration nationale.


Pour la définition, vous trouvez les informations dans le guide disponible sur la Page "Votre guide pour bien géoréférencer vos projets BIM"


2. Le géoréférencement dans Archicad, Revit et dans les IFC


    2.1 Archicad


Dans Archicad, le processus de géoréférencement n’est utilisé que pour les échanges IFC, car il n’est pas possible de créer .dwg géoréférencé, par exemple.
Vous ne pouvez pas géoréférencer votre projet avec les coordonnées dans Emplacement Projet que vous avez dans : Options > Préférences Projet > Emplacement Projet… Ces coordonnées servent exclusivement à :

  • la géolocalisation du projet dans Google Maps (Options > Préférences Projet > Emplacement Projet… > Afficher dans Googles Maps…)
  • faire des séquences solaires (Documentation > Création d’images > Créer Séquence Solaire…)
  • faire un bilan énergétique (Dessin > Estimation énergétique)

Rappel : ces coordonnées ne s’exportent pas et ne peuvent être utilisées pour le géoréférencement.


    2.2 Revit


Dans Revit, le système de coordonnées utilise :

  • le Point de topographie (Survey Point, point de géomètre; le point géoréférencé)
  • le Point de base de projet(l’origine du projet selon le confort de travail) - équivalent de l’origine de projet (croix noire grasse) dans Archicad


Ces deux points de référence sont flexibles et peuvent être déplacés librement pendant le processus de dessin. L’utilisateur peut entrer des valeurs de coordonnées (valeur UTM) du système de coordonnées globale (world coordinate system).




    2.3 IFC


Les modèles IFC mémorisent les points suivants :


  • IFC Global Origin : un point topographique qu’on peut définir comme le point géoréférencé
  • IFC Site Location : l’emplacement du site de construction (l’origine du projet)


3. Les principes du géoréférencement dans Archicad pour les modèles IFC


Pour géoréférencer son projet, dans le cadre des échanges IFC, Graphisoft a développé l’objet Point de référence de localisation qui se trouve dans la Bibliothèque intégrée (disponible en tout temps, sans avoir besoin de lier une bibliothèque).


Cet objet est à utiliser uniquement pour les échanges IFC. Il n’est donc pas possible de l’utiliser pour un fichier .dwg.


Graphisoft recommande de géoréférencer son projet dans Archicad en respectant les points suivants :


  • modéliser le projet le plus près possible de l’origine du projet (petite croix noire)
  • référencer un point topographique, commun à tous les acteurs du projet, avec l’objet : Point de référence de localisation
  • Dans les traducteurs pour l’export, utiliser le réglage par défaut Origine du projet Archicad dans Conversion géométrique > Correspondance de la position de l’entité ifcSite



  • pour les utilisateurs Revit, utiliser l'extension IFC Model Exchange with Archicad Add-in for Revit 20xx pour l’import/Export dans Revit : Lien plugin Archicad / Revit
  • Utiliser les mêmes points topographiques géoréférencés Survey Points pour enregistrer des fichier .bcf (BIM Coordination Format - page 2664 du Guide de Référence AC 24)


4. Comment géoréférencer un projet Archicad

Méthode 1 : 

géoréférencer avec un fichier .dwg de géomètre avec l’outil Dessin


Les étapes suivantes permettent de géoréférencer un projet Archicad pour l’export IFC, à l’aide d’un fichier .dwg géoréférencé par un géomètre placé avec l’outil Dessin :


  1. Ouvrir un fichier vierge d’Archicad
  2. Sélectionner l’outil Dessin et entrer dans les Options par défaut de l’outil pour cocher Utiliser origine interne du dessin comme pour ancrage et valider avec le bouton Ok.
  3. Ensuite, il est très important de ne PAS cliquer n’importe où mais sur l’origine du projet Archicad ( x ), puis de choisir le fichier .dwg et de valider l’unité de dessin. Vous aurez ainsi le fichier géoréférencé du géomètre correctement placé.
  4. Suite après la "Méthode 2".


Méthode 2 :

Géoréférencer avec un fichier .dwg de géomètre placé comme Xref


Les étapes suivantes permettent de géoréférencer un projet Archicad pour l’export IFC, à l’aide d’un fichier .dwg géoréférencé par un géomètre placé comme Xref :


  1. Ouvrir un fichier vierge d’Archicad
  2. Placer le fichier .dwg comme Xref, avec sa propre origine, dans l’origine de projet
    Fichier > Contenu externe > Attacher Xref…
  3. Suite à la fin de cette méthode.

Après avoir choisi une des deux méthodes, veuillez suivre les procédures suivante :


  1. Une fois le .dwg placé, faire un zoom arrière pour rechercher l’origine du projet Archicad ( x ). Une fois trouvé, placer dessus l’objet Point de référence de localisation, qui se trouve dans la bibliothèque intégrée d’Archicad, dans le dossier IFC.bundle. N’oubliez pas de décocher le paramètre Suivre nord du projet.

  2. En optimisant la vue et sélectionnant tout, on remarque que le .dwg placé se trouve très loin de l’origine du projet Archicad. C’est normal, car son origine se trouve à l’origine du géoréférencement (en Suisse à la MN 95), c’est-à-dire, à quelques milliers de kilomètre vers l’Est et vers le Nord.
  3. Dans Archicad, tout comme dans d’autres logiciels, il n’est pas conseillé de modéliser son projet aussi loin de l’origine du projet. Il faut donc déplacer l’importation .dwg vers l’origine du projet. Si vous avez choisi la méthode 2 avec le Xref, il faut d’abord :

    - Rendre éditable le .dwg en le liant dans le Gestionnaire de Xref puis sélectionner tout le .dwg et déverrouiller le calque


  4. Ensuite, sélectionner tout (dwg + l’objet Point de référence de localisation qui se trouve sur l’origine du projet) et déplacer le projet au plus proche de l’origine d’Archicad. Le Point de référence de localisation, avec les coordonnées X et Y sera quant à lui déplacé vers l’origine de la MN 95.

  5. Maintenant que le dwg se trouve proche de l’origine du projet Archicad et que l’objet Point de référence de localisation est lui à l’origine de la MN 95 en direction de l’Ouest et du Sud, il reste à gérer l’orientation du projet, car actuellement il n’est pas confortable de travailler avec cette orientation.
    Le nord du projet (nord géographique) qui est pour le moment à la verticale et pointe en direction du haut va bouger avec la nouvelle orientation.

    Il faut également ne pas oublier de régler l’altitude du site pour l’export géoréférencé.

    Pour réorienter le projet, il faut tout sélectionner (y compris l’objet Point de référence de localisation) et tourner le dwg selon le confort de travail rechercher.


Avant la rotation :


Après la rotation : 


Comme l’objet Point de référence de localisation a également été sélectionné, il se tourne aussi et pointe vers le vrai nord.

Attention
les coordonnées qui s’affichent après la rotation de l’objet ne sont plus les coordonnés selon la MN 95 car elles sont calculées dans le système de coordonnées du nord du projet (nord personnalisé - la direction « verticale « ), et pas selon le vrai nord !


Pour régler l’altitude du projet avant l’export, il faut :

  • sélectionner l’objet Point de référence de localisation
  • changer l’altitude de l’objet selon l’altitude du modèle, mais dans le sens inverse. Exemple : si le site se trouve à 802.87 m d’altitude, il faut choisir à Niveau de la mer et taper 0.00 m. Le niveau sera alors en négatif, c’est normal !


Une fois qu’on a réglé l’altitude et l’orientation, on peut déjà commencer à modéliser le projet Archicad en utilisant le .dwg comme référence, par exemple.


Il peut être utile de faire un export IFC du fichier vide (qui ne contient que l’objet Point de référence de localisation) et de l’ouvrir dans Revit, par exemple, pour obtenir un projet Revit géoréférencé.


Remarques :

  • l’export avec l’objet Point de référence de localisation masqué fonctionne sans problème. Il est donc recommandé, pour le confort du travail, de créer un calque pour cet objet et de masquer celui-ci.
    Cependant, il ne faut pas placer plusieurs fois cet objet dans le même projet. Dans l’éventualité où il y en aurai plusieurs, seul le premier placé sera utilisé pour les exports IFC.

  • Malheureusement encore beaucoup d’utilisateurs ne connaissent pas la méthode du géoréférencement et utilisent le fichier du géomètre géoréférencé avec son origine très loin de l’origine du projet Archicad, ce qui peut engendrer divers problèmes dans le modèle.